Outlaw Audio home shop products hideout news support about
Topic Options
#99349 - 04/27/24 04:57 PM 7700 amp not powering on
zuter Offline
Gunslinger

Registered: 02/17/11
Posts: 18
This just happened today after years with no issues.
My amp (7700) didn't power on when starting my system. I use the remote trigger from my Marantz 7005 to the amp for auto start. It shows the red light on the amp power button but won't turn blue after my system powers up (this usually takes 30 seconds or so). I tried manually starting it, no joy. I turned off the amp and removed the remote trigger cable then tried switching it on manually but still nothing. If I hold down the power button I can hear it click but nothing else happens. I've unplugged then tried all again, still nothing.
Any suggestions or is it dead?
Thanks in advance.
_________________________
Axiom M80-V3 HT 7 channel setup (2-M80's, VP180 and 4-QS8's) - minus sub
Marantz AV7005
Pioneer Elite PRO-101FD Plasma monitor
OPPO 103 Bluray Player
Home built HTPC
Outlaw 7700 amp

Top
#99350 - 04/28/24 01:34 PM Re: 7700 amp not powering on [Re: zuter]
butchgo Offline
Desperado

Registered: 06/22/07
Posts: 369
Loc: Southern Oregon coast
Best thing to do is go to Outlaw's website and open a service ticket and see what they suggest.
_________________________
Epson 3500 3D projector
93" Carl's Place Flexiwhite DIY screen
Outlaw 976 Pre/Pro
Outlaw 7500 for LCR & L/R surrounds
1- Emotiva Mini X-A100 for rear surrounds
2- Outlaw LFM-1 EX subs
Oppo BDP-105 Blu-ray/DVD/SACD player
Outlaw LCR (Snell Labs) for center channel duty
Tekton Lore monitors L/R
4- Emotiva ERD-1s surround speakers
Monster HTS3600MKII power center

Top

Who's Online
0 registered (), 288 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
jamescuz, Zilla8d3, waferman, picnicjc, Hedoboy
8709 Registered Users
Top Posters (30 Days)
M.Yu 1
Forum Stats
8,709 Registered Members
88 Forums
11,328 Topics
98,694 Posts

Most users ever online: 488 @ 06/18/24 10:00 AM