Outlaw Audio home shop products hideout news support about
Page 1 of 2 1 2 >
Topic Options
#95928 - 07/31/16 08:55 AM RR2150 no sound
steve1173 Offline
Gunslinger

Registered: 04/29/02
Posts: 45
Loc: punta gorda, florida, usa
Have not used my RR2150 for about 2 weeks, turned it on this morning no sound. All the lights work, the remote works turns volume control up/down, all sources, fm, cd, etc. The amp is not putting out. Had it on power strip with my cd, read online plug directly in outlet still no sound. When I turn it on or off with master switch in back it clicks on powers up no sound. Any ideas, is there a fuse, gonna call outlaw Monday to see what they say, have it about 3 years.

Top
#95929 - 07/31/16 01:24 PM Re: RR2150 no sound [Re: steve1173]
rdgrimes Offline
Gunslinger

Registered: 10/31/14
Posts: 33
? Try a different input on the 2150?

Top
#95930 - 08/01/16 03:46 AM Re: RR2150 no sound [Re: steve1173]
steve1173 Offline
Gunslinger

Registered: 04/29/02
Posts: 45
Loc: punta gorda, florida, usa
Have tried all inputs, fm, cd, even tried speaker a, b. Left it on for 1 hr, noticed top cut slightly warm as when working normally so amp must be getting power

Top
#95931 - 08/01/16 06:12 AM Re: RR2150 no sound [Re: steve1173]
XenonMan Offline
Desperado

Registered: 04/08/08
Posts: 2402
Loc: Columbus,North Carolina
Unlikely it is a fuse if the front display lights up. Call Outlaw for troubleshooting and repair. Their rates are really fair.
_________________________
Music system
Model 990/7500/Magnepan 1.6 QRs/Technics SL1200 MK2/Aperion S-12 Subwoofer/OWA3/Sony NS75H DVD
APC H15 Power Conditioner

TV System
Large Advent Loudspeakers/ Polk center/Monoprice surrounds/Panasonic Viera 42 inch/Onkyo HT-RC260/Sony BDP S590/Directv


Home Theater System
Onkyo PR-SC886/Outlaw 7125 Klipsch RF-82 L/R,RC-62 center, RB-35 SR/SL, BENQ HT1075, Outlaw LFM1-EX/OPPO BDP-83/Directv
Harmony ONE
Blue Jeans and Monoprice interconnects
APC H15 Power Conditioner

Top
#95932 - 08/01/16 10:48 AM Re: RR2150 no sound [Re: steve1173]
EEman Offline
Desperado

Registered: 11/11/09
Posts: 447
Loc: Canton, MI
Did the A/B zone switch get bumped to the other zone? The jumpers in the back still installed. Eliminate the obvious before calling...
_________________________
975/7075/SMS-1
Aperion Verus Grand Towers & Bookshelves, Verus Forte Center, Infinity Surrounds, Ultra-X12
Oppo BDP-103, XBOX360, Xbox One
Samsung 51" Plasma
RR2150 w/Klipsch SCR-2

Top
#95933 - 08/01/16 04:16 PM Re: RR2150 no sound [Re: steve1173]
XenonMan Offline
Desperado

Registered: 04/08/08
Posts: 2402
Loc: Columbus,North Carolina
Is the external loop button engaged and if it is is the connected gear powered up? Headphone jack is not in use? Check if speakers are connected especially if you recently moved the unit.
_________________________
Music system
Model 990/7500/Magnepan 1.6 QRs/Technics SL1200 MK2/Aperion S-12 Subwoofer/OWA3/Sony NS75H DVD
APC H15 Power Conditioner

TV System
Large Advent Loudspeakers/ Polk center/Monoprice surrounds/Panasonic Viera 42 inch/Onkyo HT-RC260/Sony BDP S590/Directv


Home Theater System
Onkyo PR-SC886/Outlaw 7125 Klipsch RF-82 L/R,RC-62 center, RB-35 SR/SL, BENQ HT1075, Outlaw LFM1-EX/OPPO BDP-83/Directv
Harmony ONE
Blue Jeans and Monoprice interconnects
APC H15 Power Conditioner

Top
#96478 - 04/05/17 04:55 PM Re: RR2150 no sound [Re: steve1173]
Briznack Offline
Deputy Gunslinger

Registered: 04/03/17
Posts: 1
Loc: Tulsa, OK
Did you ever find a solution? My 2150 just did the same thing. Headphones jack still works but no sound from the speakers and all the lights are still behaving normally.

Top
#96645 - 06/05/17 04:40 AM Re: RR2150 no sound [Re: Briznack]
steve1173 Offline
Gunslinger

Registered: 04/29/02
Posts: 45
Loc: punta gorda, florida, usa
Yes found the solution, had to send it in. Turned out to be the speaker selector switch on the front board. They replaced it and guess what after 9 months of really not using it much as I only use it for cd's and fm as I use my home theater setup more the same thing has happened again. All lights, volume control moves but no sound, am assuming it is the speaker switch again. Gonna call them today but not gonna waste the money or effort to fix it if the part only lasts 9 months with little use. If yours is doing the same thing it must be a weak spot in the unit. Went thru something like this with my 3 1/2 year old Vizio 70", no picture but soumd. Vizio knew it was a problem model E701-A3 as they extended warranty to 2 years as the displays were going bad, turned out researching it I found many complaining with same problem, called Vizio no help. Sent a letter to the attorney general with pages of findings of many breaking down same reason, Vizio customer service when I first called said is your problem no picture but sound. To make long story short got call from Vizio executive office and we talked as I knew electronics break down but the same thing in one model, I guess to prevent the attorney general from investigating he said "I have some extra money in my budget can I offer you a free 70" 4k tv". Case closed.


Edited by steve1173 (06/05/17 04:46 AM)

Top
#96646 - 06/05/17 05:02 AM Re: RR2150 no sound [Re: Briznack]
steve1173 Offline
Gunslinger

Registered: 04/29/02
Posts: 45
Loc: punta gorda, florida, usa
Just checked headphone jack, headphones work so it seems the speaker selector switch is a real weak spot.

Top
#96649 - 06/05/17 02:28 PM Re: RR2150 no sound [Re: steve1173]
Stephen B Offline
Gunslinger

Registered: 01/15/15
Posts: 205
Loc: East Texas
Bummer it has happened more than once. I wonder if there might have been a bad run of parts? Have there been reports from other owners with the same problem?

Being out of warranty are you able to replace the part on your own to save the shipping and service labor? You might consider taking the cover off and looking for a loose wire or cold solder joint.

Top
Page 1 of 2 1 2 >

Who's Online
1 registered (govguru), 40 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
BC007, klopfer, JPSAZ, George Farber, shokubry
8211 Registered Users
Top Posters (30 Days)
XenonMan 21
mdanderson 19
Owl's_Warder 15
AvFan 15
butchgo 10
Forum Stats
8,211 Registered Members
78 Forums
10,989 Topics
96,644 Posts

Most users ever online: 252 @ 10/08/16 06:08 PM