Outlaw Audio home shop products hideout news support about
Page 1 of 5 1 2 3 4 5 >
Topic Options
#71915 - 04/08/06 11:09 PM 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I just received a b-stock 1070 today. Initial impressions after a few hours of playing:

Build Quality
Very nice sturdy construction. Simple and uncluttered. I love the all metal binding posts. While unpacking I did notice that one of the screws securing the RS-232 port was loose, and the other one missing. Luckily I found it rolling around in the bottom of the box. One of the screws holding the back panel on the 1070 was halfway unscrewed as well. No batteries were included for the remote.(Note: This is a b-stock unit)

Set-up
Pretty straight forward following the manual. It would be nice if there could be separate speaker settings for each input. For example, I usually watch television with speakers set to large and switch them over to small to watch DVDs or listen to CDs.

The on-screen display is very nice...and it needs to be. As others have noted, the display on the front of the 1070 is simply a cruel joke. The text is tiny and unreadable from more than a few feet away.

Remote
Cleanly designed and layed out, and I like the blue back-lighting. The buttons are nicely sized, shaped, and spaced. I already have issues with the way it functions however. I find it odd and uncomfortable having to press one of the source buttons (DVD, VIDEO 1, CD) to turn on the receiver. The manual notes that this is helpful for the use of programmable remotes - perhaps I'll appreciate this more after picking up a Harmony.

I also find it odd that I cannot change surround modes while the remote is set to operate my cable box. I have to switch the remote back over to TNR before I can try a different Dolby or PLII mode, for example. On the other hand, the Volume Control Punch-Through function is very handy, and allows the use of the volume and mute controls to operate on the receiver even when the remote is set to operate another device.

Speaking of surround modes, it does not appear that I can use five or seven channel stereo mode when listening to 'digital' cable channels (only the analog channels). This is our preferred surround mode for television (with the exception of movie channels broadcasting in Dolby 5.1). If I am missing something...please let me know as we are not thrilled about this limitation.

I was able to set-up the remote to operate my cable box, TV and CD player using the preprogrammed codes, but not my DVD/VCR combo. I already miss having a learning remote.

Video-switching
I am using three video feeds switched through the 1070 - digital cable through an S-Video cable, DVD player through component, and VCR over a composite cable. The video out to my TV is through a component cable. Though I have not tried the VCR yet, the picture on cable and DVD are excellent.

Sound
I have only listened to bits and pieces of music and movies and television, so I can't give a full report on sound quality. I will say that I was a little concerned going from a "110" watt per channel receiver to the Outlaw rated at 65 watts per channel, but it turns out I had nothing to worry about...the Outlaw sounds more dynamic and powerful than my old receiver (Note - my speakers are from Ascend Acoustics and are not difficult loads to drive).

Top
#71916 - 04/09/06 04:18 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Day 2
Watched Memoirs of a Geisha on DVD. Sound was very good. My wife's unsolicited input matched my own thoughts - better power and clarity than our old receiver.

On the downside, I already experienced two 'no audio' incidents while surfing digital cable - change channels and all of a sudden there is no audio. The only way I found to get it back was to turn off the receiver and turn it on again. For now I've set that Video input's audio to "analog" thinking that this issue is some result of auto-polling or other digital-analog anomaly. This also allows us to watch all channels using the five channel stereo mode that I mentioned in my original post.

Top
#71917 - 04/13/06 03:47 PM Re: 1070 - Initial Impressions
Dave Gross Offline
Gunslinger

Registered: 03/06/06
Posts: 21
Loc: Seattle
Chas..why are you using S-Vid out of your digital cable box?? Doesn't it have component or HDMI? I've got the Comcast box, and using the Outlaw HDMI-DVI cable, it works amazingly well.

I've got a 42" NEC 42xr4a Plasma, and even the difference between Component in and HDMI is stunning.

I've been doing a LOT of experimenting with setups..and I still may just DIRECT to the TV with the HDMI out of the DVD and Cable box. Then, run one component out of the 1080 into the unit as well for OSD (and eventually XBOX 360).

Today..I'm gonna attempt to get the Harmony 880 remote working with everything...
_________________________
dave gross
helldogmusic.com

Top
#71918 - 04/13/06 03:58 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
If it's an HD cable box, it should have at least component and possibly DVI or HDMI. If it's a standard digital cable box, he's probably lucky to have s-video out.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71919 - 04/13/06 10:21 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Gonk is correct...I only have a standard box and S-Video is the best it offers.
I'll be interested to hear how the Harmony works with the 1070...

Top
#71920 - 04/29/06 02:44 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Since I am still within the 30-day trial period with the 1070 I have been trying to decide if the Outlaw is a keeper.

Last weekend my wife suggested we try a back to back test with a couple of movie scenes - first with our old receiver and then with the Outlaw. She picked the Lobby Shooting Spree from The Matrix and I chose The Bridge of Khazad-dum from The Fellowship of the Ring (Extended Edition DTS track).

I have said very little to my wife regarding the Outlaw, as I wanted an uninfluenced opinion. Her comments were as follows:

1. Our old receiver sounded good with both scenes - but the Outlaw sounded better.

2. Our old receiver played just as 'loud' but did not sound as powerful as the Outlaw. During the loudest parts the sounds across the front speakers were sort of 'mashed together' with the old receiver, but remained separate and more distinct through the Outlaw.

3. The sound from all five speakers seems to blend together as a whole better through the Outlaw. With the old receiver it's easier to tell that the sound is jumping from speaker to speaker.

4. High frequencies were more clear and more realistic with the Outlaw. They sounded a little more "tinny" through the old receiver (shell casings hitting the floor in The Matrix for example).

5. Dialog was more clear with the Outlaw (specifically Gandalf's voice...which for me has always been a bit hard to understand during some parts of the Lord of the Rings).

I have to say I was very impressed with the feedback I received from my wife. She has no interest in the technical aspects of this hobby but she does appreciate good sound and probably has a better ear than I do.

On the downside, the operation of the remote continues to bug me. I still like the overall look and feel of the unit, but why can't it just have a power button for the receiver and a source power button? With my old remote I could just press two buttons and be surfing digital cable. With the Outlaw remote I have to punch five buttons to be in business. And why do I have to switch back to TNR to access the Dolby/DTS/Stereo mode buttons??

One final note - The Bourne Supremacy sounded fantastic on Encore today....

Top
#71921 - 04/29/06 06:58 PM Re: 1070 - Initial Impressions
Ragnar Offline
Gunslinger

Registered: 05/02/05
Posts: 49
chas,
Glad to hear your enjoying the sound quality of the 1070. I too very much enjoy the sound. However, I have the same misgivings about the remote, specifically with the lack of a power on.

Have you experienced any more "no audio's"?
Ragnar

Top
#71922 - 04/29/06 10:01 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I have had my cable tv input set to analog to avoid the no-audio issue. Today I set it back to the digital coax input with auto-polling on to watch some movies on cable and have had no issues. Outlaw tells me another firmware update is coming soon.

Top
#71923 - 08/26/06 05:33 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I did end up returning the 1070 after an extended audition period (thanks Outlaw for letting me keep it a couple extra weeks!). The "no-audio" issues continued to haunt my 1070 and since we moved this summer I really did not have the time to experiment with the latest firmware update.

I admit however, that I do miss the performance of this receiver. My old receiver just doesn't have the punch and clarity of the 1070.

Here's my wish list for the next generation of the Outlaw receiver:

1. Fully resolved no-audio issue (has the latest firmware resolved all issues?)
2. Discrete on button for the remote. This (along with the no-audio issue) was the most frustrating thing for my wife.
3. 5/7 channel stereo mode for all sources.
4. Speaker settings for each input (speakers set for large on one output, small on another). I believe some HK's have this ability and I would love it, since I frequently switch this around depending on what I'm using the receiver for at the time.
5. Learning remote.

Give me these and I'll be first on the waiting list for the '1090' !

Top
#71924 - 08/26/06 06:20 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
That's a pretty good list. I'd hope that the source buttons would always double as discrete on commands (since it really is handy for macros).

Quote:
5/7 channel stereo mode for all sources.
This is limited to stereo inputs because using it with other sources (speaking here of Dolby Digital and DTS) would require downmixing to stereo first - which would effectively defeat the purpose of DD and DTS.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71925 - 08/26/06 07:29 PM Re: 1070 - Initial Impressions
Belgand Offline
Gunslinger

Registered: 08/23/05
Posts: 59
Loc: San Francisco, CA
Odd, I have the no-audio issue on my non-digital inputs! Speficially it will show up sometimes when I switch to my TiVo, which only has analog audio out. In these cases I just need to switch inputs and the problem will usually go away, but it is irritating.

I also use a Harmony remote (676) on my system and it works perfectly. Setting it up was a bit of a pain (they have a bit too much hand-holding which makes it hard to configure exactly the way you want when you know what you're doing, but you can usually eventually find a way around it), but once everything is set it works great. Transitioning from TiVo to a DVD is almost perfectly seamless and you no longer think about how a remote works or what the correct buttons are, you just press the "play" button or "pause" button regardless of what mode you're in and know it will do what it aught to. I've found that it works excellently with the 1070 although it does require a bit of tweaking to get the codes set up correctly as the defaults are a bit poor and, IIRC, are missing the Video 4 inputs.

As a result of this I'm also a bit unique in that I want less emphasis on a good remote. Yes, it should be usable and workable for those who buy it, but since I'm just going to stick it in a drawer and use a third-party remote I'd rather they cut the costs on it rather than try to make a really exemplary remote with plenty of features (i.e. learning).

Top
#71926 - 08/26/06 07:32 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Gonk, do you know if there are still no-audio issues out there with the latest firmware?

I agree that I would never use the all channel stereo for a 5.1 encoded source, but I usually listen to television using the 5/7 channel stereo modes, and was not able to use this for 'digital' cable channels broadcast in stereo with the 1070. All other receivers I've owned have had this capability.

Top
#71927 - 08/26/06 07:36 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Belgand....I agree that if a learning remote adds substantially to the cost I can do without that feature. Just give me an "on" button and I'd be happy enough!

I also had no-audio issues even after removing the digital connection to my cable box and running strictly analog. Is this with the latest firmware?

Top
#71928 - 05/18/07 01:13 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Despite the fact that I returned the 1070, I've never been able to get it out of my mind. I've been through three mid-level receivers since then and they were all fine but uninspiring. I just bought a used 1070 on Audiogon...should arrive next week. We'll see how I like it the second time around!

Top
#71929 - 05/18/07 02:00 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
Let us know how it goes, chas.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71930 - 05/18/07 03:22 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Will-do Gonk...

Top
#71931 - 05/18/07 04:58 PM Re: 1070 - Initial Impressions
Lizard King Offline
Desperado

Registered: 08/30/06
Posts: 425
Loc: NY
Hey Chas, let me know how you like the 1070. Be sure to good audiophile type speakers Chas. I am using Alon 2 Mk2 , HSU VTF-2 MK2, Ascend 340C (classic) and Ascend HTM-200's.

Liz
_________________________
Outlaw 1070, Anthem MCA5 II amp.
Sony Ps3
Alon 2 Mk2 Loudspeakers
HSU VTF-2 Mk2 sub x2
VAC PA100/100 Tube Amp
ARC SP16-L tube Preamp
Audio Note Dac 2.1 "B" signature
Furutech E-TP80,
Ascend HTM-200, 340C
Sony KDS-55A2020

Top
#71932 - 05/18/07 05:06 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I had Ascend 340 classics...just sold them and moved into the Ascend 340SE's.

Top
#71933 - 05/18/07 07:24 PM Re: 1070 - Initial Impressions
Lizard King Offline
Desperado

Registered: 08/30/06
Posts: 425
Loc: NY
Hey Chas,

My buddy Bill has 340 classic in his attic. He used to play them , now he uses better speakers. How do you like the SE compared to the classics?
_________________________
Outlaw 1070, Anthem MCA5 II amp.
Sony Ps3
Alon 2 Mk2 Loudspeakers
HSU VTF-2 Mk2 sub x2
VAC PA100/100 Tube Amp
ARC SP16-L tube Preamp
Audio Note Dac 2.1 "B" signature
Furutech E-TP80,
Ascend HTM-200, 340C
Sony KDS-55A2020

Top
#71934 - 05/18/07 08:02 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I like them. The deeper bass extension is noticeable.

Top
#71935 - 05/25/07 02:15 AM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Well I received my used 1070 from UPS today and got it set-up this evening. Wow.

I remembered the 1070 as being a great sounding receiver, but second impressions reinforce the fact that this thing is in a different league than the usual receivers found in the B&M stores.

I never have been satisfied listening to two channel music without a sub using other receivers (and I've had 7 of them)...even in so-called pure direct modes. The Outlaw in Bypass hooked up to a Denon CD player sounds full-bodied, rich and detailed. Voices and instruments separate nicely and bass is strong enough to satisfy without a sub.

So far I'm extremely happy to have a 1070 back in the rack.

Top
#71936 - 05/26/07 03:32 PM Re: 1070 - Initial Impressions
Lizard King Offline
Desperado

Registered: 08/30/06
Posts: 425
Loc: NY
Hey Chas,

Glad to read you are back up and running. Try hooking your Denon DVD player via analog interconnects into the Multi hcannel DVD input. Once you do that, slect DVD on the rEmote control then select the 7.1 button on the remote control. Be sure to move teh toggle switch for bass management all the way up before you do this.

Trust me, this is the best method!
_________________________
Outlaw 1070, Anthem MCA5 II amp.
Sony Ps3
Alon 2 Mk2 Loudspeakers
HSU VTF-2 Mk2 sub x2
VAC PA100/100 Tube Amp
ARC SP16-L tube Preamp
Audio Note Dac 2.1 "B" signature
Furutech E-TP80,
Ascend HTM-200, 340C
Sony KDS-55A2020

Top
#71937 - 05/26/07 03:35 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I'll give that a shot Liz...thanks for the tip.

Top
#71938 - 05/26/07 03:44 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Actually I have a Denon CD player...not a multichannel-out DVD player, so I don't think I can use that technique as I have no sub-out to connect to the multichannel in.

Top
#71939 - 05/26/07 05:56 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
Lizard king's technique would still work with a standard CD player - just connect the left/right outputs to the left/right channels of the DVD input and set the switch on the back to "HPF/LPF". The 1070 will generate a signal for the sub and the signal path will be purely analog from end to end.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71940 - 05/26/07 08:27 PM Re: 1070 - Initial Impressions
Lizard King Offline
Desperado

Registered: 08/30/06
Posts: 425
Loc: NY
Chas,

Listen to Gonk, He is the expert! You wnat to keep the signal in the analog world!
_________________________
Outlaw 1070, Anthem MCA5 II amp.
Sony Ps3
Alon 2 Mk2 Loudspeakers
HSU VTF-2 Mk2 sub x2
VAC PA100/100 Tube Amp
ARC SP16-L tube Preamp
Audio Note Dac 2.1 "B" signature
Furutech E-TP80,
Ascend HTM-200, 340C
Sony KDS-55A2020

Top
#71941 - 05/26/07 08:28 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I did try it Gonk...but got nothing from the sub.

Top
#71942 - 05/26/07 09:42 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
The crossover used when the switch is set to HPF/LPF is at 80Hz. I'd generally recommend making sure that the bass management in the player is disabled, but a CD player shouldn't have that issue. What you may want to do is try some test tones (my Devious Tiny Disc would suffice) to make sure you are providing a signal with content below 80Hz - a lot of music won't dip that low.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71943 - 05/26/07 10:24 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
I'll keep playing with it. I thought some of the bass notes got low enough but maybe not. There's nothing else to set up other than the switch to HPF/LPF, analogs in on the 7.1 inputs unit switched to DVD and 7.1 Bypass engaged?

I'll break out the test tones when I get a chance. Thanks Gonk.

Top
#71944 - 05/27/07 06:47 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Hooked up to the analog cd inputs I noticed the sub was playing even though the speakers were all set to large and I was in bypass. I discovered I had accidentally set the subwoofer in the menu to "LFE". Does this need to be set to LFE to get the sub active on the 7.1 inputs?

Top
#71945 - 05/28/07 01:02 PM Re: 1070 - Initial Impressions
Alexandru Mihaita Offline
Gunslinger

Registered: 04/17/07
Posts: 132
Loc: Springfield, PA
When in "bypass" mode and analog inpout, what really counts is the toggle on the back of the unit. Make sure it's in "bypass" position (the middle position) as well.
If it's in LPF/HPF it will engage the passive analog crossover and frequencies below 80Hz will go to your sub.
The manual makes you believe the toggle on the back applies only to 7.1 bypass mode, but in fact it applies to everything analog in bypass mode, including the tuner.
That toggle on the back of the unit is the equivalent of "analog bass management", if you want, the signal doesn't go through A/D/A phases as DSP circuit is bypassed while still allowing listeners with small speakers and sub use the unit in stereo bypass mode.
_________________________
Alex

Top
#71946 - 05/28/07 02:06 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Thanks Alex. I'm still experimenting with sub and switch settings. What I found odd is that in bypass on the CD analog inputs, when the sub was engaged (when I had it set to LFE in the menu and the switch set to LPF/HPF) the sound volume was lower than when the sub was set to none.

Top
#71947 - 07/05/07 04:59 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
To update on life with my second 1070...

Within the last week I had two "no-audio" incidents - turned on the 1070, then my tv and satelite receiver and had no sound. Switching to another input and then back again restored audio.

The last incident I had followed the same steps, but instead of no-audio I got muffled, static filled audio. When I switched to another input and back again I got a loud screeching sound from my speakers and quickly turned off the 1070. After turning it back on everything was fine again.

After that incident I downloaded the new official firmware update and installed it. The process was quick and painless. I've used the 1070 several times since then and so far have had no issues of any kind to report.

Top
#71948 - 07/05/07 10:08 PM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
That's good news. Hopefully with the new firmware you can leave those problems behind you.
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71949 - 08/04/07 02:40 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
Well I've had a couple instances of no-audio with the newest firmware. This was with a satelite receiver connected with analog audio and auto-polling set to off. A couple were remedied by switching to another source and back, and others had to power off and back on to get audio going.

Top
#71950 - 08/04/07 03:20 PM Re: 1070 - Initial Impressions
og33 Offline
Gunslinger

Registered: 05/30/07
Posts: 185
Loc: White Cloud, Michigan
Chas,
Have you noticed any 'no audio' problems with digital audio sources since you did the firmware update?
_________________________
HT:
Pioneer VSX-1120
Salk Songbirds, SongCenter, SongSurrounds
Panasonic BDP-45
Outlaw LFM-2

2 Channel:
Red Dragon M-500 monoblocks
BAT-VK3i
Salk HT-1TL's
Apple TV
Beresford 7520 DAC
Surgex XS10

Top
#71951 - 08/04/07 05:22 PM Re: 1070 - Initial Impressions
chas Offline
Gunslinger

Registered: 10/21/05
Posts: 142
Loc: Minnesota
No, I have not.

Top
#71952 - 08/04/07 08:07 PM Re: 1070 - Initial Impressions
og33 Offline
Gunslinger

Registered: 05/30/07
Posts: 185
Loc: White Cloud, Michigan
Thanks Chas. I'm just wondering since due to WAF (990 too big) I am going to the 970. Other than 5.1 analog in..all my connections are digital.
_________________________
HT:
Pioneer VSX-1120
Salk Songbirds, SongCenter, SongSurrounds
Panasonic BDP-45
Outlaw LFM-2

2 Channel:
Red Dragon M-500 monoblocks
BAT-VK3i
Salk HT-1TL's
Apple TV
Beresford 7520 DAC
Surgex XS10

Top
#71953 - 08/05/07 02:06 PM Re: 1070 - Initial Impressions
Bob Becker Offline
Gunslinger

Registered: 02/10/07
Posts: 130
Loc: Washington, D.C.
I have had a new problem with the 1070 that I don't understand. Sometimes when switching between sources the 1070 just freezes. It will not do anything until the power button on the back is turned off and back on. It will not even go to sleep when the front powere button is pushed. This started happening as I began programming a URC MX-850 remote. I suspect it has something to do with the timing of commands send when a macro is running, but haven't been able to isolate the problem. It appears to happen when switching between sources, i.e. digital tv tuner and DVD, which uses analog audio inputs and HDMI-DVI video.
_________________________
Robert S. Becker, Esq.
http://www.dcappeals.com
rbecker@dcappeals.com

Top
#71954 - 08/10/07 06:25 PM Re: 1070 - Initial Impressions
Alexandru Mihaita Offline
Gunslinger

Registered: 04/17/07
Posts: 132
Loc: Springfield, PA
My conviction is that anyone who still believes that the no-audio bug will be solved needs to wake up. It's never going to be solved, especially since 1070 is no longer produced.

When I read Scott's announcement with respect to Model 1070 being phased out, my hope to ever have the issue fixed just disappeared. I nourished that hope, even thought that maybe a recall is imminent given Outlaw customer support reputation. Boy, was I wrong.

The unit does all kind of weird things, albeit sporadically, truth to be said, including some beyond the "just inconvenience" threshold. I was watching a DVD and when the intro section of the DVD, usually in two channels, ended and the audio switched to true 3/2.1, a piercing, very loud sound, started to be emitted from all speakers. I reached for the remote in a state of true panic and depressed the power button. Then I depressed "DVD" and the sweet Outlaw sound resumed. I had to calm down my family and explain that it was not a smoke detector or fire alarm going off, but simply daddy's AV receiver...

Other times the unit simply loses a channel, when switching sources. A source bounce usually fixes it. This is especially annoying, for it's not immediately obvious, like the true "no audio".

Ultimately, the pleasure of that sweet Outlaw sound is now replaced by tension. Would that aggressive sound start again? Are all channels on? It may seem ridiculous, but when a DVD movie really starts I "take a tour" and listen to all speakers to make sure the DSP got them all and nothing is dropped. High tech, isn't it?
This is it. I'm stuck with a unit I haven't returned in the first 30 days because I truly loved and still love its sound and I hoped that the problems will be fixed by upgrades.
_________________________
Alex

Top
#71955 - 08/10/07 06:41 PM Re: 1070 - Initial Impressions
RedSIinPA Offline
Gunslinger

Registered: 12/28/06
Posts: 278
Loc: Outside Phila.
Alex -

I don't think I've reached the same point you may have, but I empathize. Just an FYI, I have heard this loud distorted blaring sound when I would switch Dolby/DTS modes. It wasn't loud enough to do any damage and I think it was relative to the volume I had the 1070 at when it happened.

I have to admit, although I'm still an Outlaw fanatic at heart, I wasn't thrilled that I applied the firmware per all the advice of the Outlaw folks on their site, the upgrade bombs, and I'm left bucking up to return the unit to them for repair. {edit: let me make it clear, I can understand this is the 'cost' of ownership, and I didn't lose sleep over it. But WAF can be a little harsh on the toys under these circumstances. And I see the point, even though I'm biased toward my 1070.)

I can only hope that when I receive my unit back today, that most of the problems are resolved. While none of them were show stoppers prior to the failed upgrade, they were nuisances that, coming from a software background, should have been resolved.

I know I'll have to just suck it up until it's time to replace it, but I don't want to do that for some time. Let's just say I'm not 100% satisfied (more like 98%) and I'm a little spoiled. Also helping me is the fact that the 1070 was a gift. Had it been my $1K, I might be a little more irked. I can deal with it assuming the problems don't worsen.If they do, I may be responding to this again. But I truly hope that the 1070 is my receiver for some time to come. I do love the 1070 when it's working right and I think my 1070 was definitely less buggy than yours.

Good luck with your setup. If you're really upset about it, I would contact Outlaw. I would think they would hear you out. You seem to be a reasonable guy and have been patient through the woes.
_________________________
Model 1070
Toshiba HD-A35 & Pioneer BDP-51
Tivo Series 3
Elite 50" / Aquos 32"
Squeezebox Radio

Stereo Setup:
NAD C326BEE (50Wx2)
Elite DV-47Ai Universal SACD/DVD-A
Citypulse DA7.2x II + TXCO DAC
B&W 685s
JL Fathom F112
Denon AH-D2000 Headphones


Top
#71956 - 08/12/07 01:32 AM Re: 1070 - Initial Impressions
RedSIinPA Offline
Gunslinger

Registered: 12/28/06
Posts: 278
Loc: Outside Phila.
I'm glad to announce that I've had my 1070 back for 6 hours and no problems whatsoever. It's good to have it back!!

And on a side note, not to sidetrack, but I've traded my Atlantic Tech 2200 speakers (5) for an Earthquake Sound Saturn Orbital 5 channel setup. The 2200's weren't cutting it for the room I was now viewing in. I'm THRILLED with the new sound in my room. These speakers, although probably quite unknown to the masses, are performers.

Happy to be back!
_________________________
Model 1070
Toshiba HD-A35 & Pioneer BDP-51
Tivo Series 3
Elite 50" / Aquos 32"
Squeezebox Radio

Stereo Setup:
NAD C326BEE (50Wx2)
Elite DV-47Ai Universal SACD/DVD-A
Citypulse DA7.2x II + TXCO DAC
B&W 685s
JL Fathom F112
Denon AH-D2000 Headphones


Top
#71957 - 08/12/07 01:42 AM Re: 1070 - Initial Impressions
tru blu Offline
Desperado

Registered: 09/04/06
Posts: 406
Loc: Brooklyn, NY
Great news, indeed, Red. And time to upgrade your Saloon signature...btw, where'd you find out about the Earthquakes? Just curious...
_________________________
This ain't for the underground. This here is for the sun."
-Saul Williams

Top
#71958 - 08/12/07 01:45 AM Re: 1070 - Initial Impressions
gonk Offline
Desperado

Registered: 03/21/01
Posts: 14054
Loc: Memphis, TN USA
Good to hear that you're up and running again!
_________________________
gonk
HT Basics | HDMI FAQ | Pics | Remote Files | Art Show
Reviews: Index | 990 | speakers | BDP-93

Top
#71959 - 08/12/07 03:36 AM Re: 1070 - Initial Impressions
RedSIinPA Offline
Gunslinger

Registered: 12/28/06
Posts: 278
Loc: Outside Phila.
Quote:
Originally posted by tru blu:
Great news, indeed, Red. And time to upgrade your Saloon signature...btw, where'd you find out about the Earthquakes? Just curious...
Originally I heard about Earthquake via my father in law. He was looking into a new sub for his ever changing HT and ran across some reviews of their SuperNova series. He and my wife eventually conspired to get me one of their MKIV 12's which has a passive and active woofer built into one enclosure. I thought the world of that sub from the day I hooked it up. (I still own it and use it in my gaming 'rig'.)

I had quite some time to sample the Orbital setup as it was in my FIL's house for a couple months. He had it in his back "den" area which was a separate HT room with XB360, a 55" SXRD, and a HK receiver. I knew the Outlaw would do them right, so we basically worked out a trade after I had some time with the speakers. They are beautifully constructed for their price range. I've already put in a couple demo movies and I have to say I'm thrilled it's worked out this way. I'll miss my AT's but they were simply tooooo small for this room. They were drowning in this space.

PS - anyone who's read my posts for the last few months knows I've been hinting at getting legitimate towers for my music listening, and at last, I've got them. they don't make a smiley icon that best represents how I'm feeling right now.
_________________________
Model 1070
Toshiba HD-A35 & Pioneer BDP-51
Tivo Series 3
Elite 50" / Aquos 32"
Squeezebox Radio

Stereo Setup:
NAD C326BEE (50Wx2)
Elite DV-47Ai Universal SACD/DVD-A
Citypulse DA7.2x II + TXCO DAC
B&W 685s
JL Fathom F112
Denon AH-D2000 Headphones


Top
#71960 - 08/12/07 04:54 PM Re: 1070 - Initial Impressions
tru blu Offline
Desperado

Registered: 09/04/06
Posts: 406
Loc: Brooklyn, NY
I'll tell you, Red, it's great reading about someone's spouse totally indulging the audio hobby. "Conspiring" with your father-in-law? My wife really loves the sound of my recently upgraded system, but so far she's pretty content to leave the research and acquisitions to me. Of course, I'm pretty sure that could change if we eventually move into a house and my spending threatens to really get out of control. Enjoy.
_________________________
This ain't for the underground. This here is for the sun."
-Saul Williams

Top
#71961 - 08/13/07 02:02 AM Re: 1070 - Initial Impressions
RedSIinPA Offline
Gunslinger

Registered: 12/28/06
Posts: 278
Loc: Outside Phila.
I wouldn't call my wife's cooperation "totally indulging", but I would admit that she's pretty good about it. It really helps that her father is the same way. He and I are both into cars, computers, and A/V. In general I'm generally not denied anything within reach. She's the budget person so if it's not feasible, I'll know that. If I were single, I'd have all these toys and maybe more, but then I'd be late on other less important payments, such as the electricity, or heating. laugh

I played hell getting her to warm up to floor speakers. I had to conspire with her parents to wear her down with the "the finish of those speakers will look so nice on your hardwood floors..." it took weeks for her to cave. cool
_________________________
Model 1070
Toshiba HD-A35 & Pioneer BDP-51
Tivo Series 3
Elite 50" / Aquos 32"
Squeezebox Radio

Stereo Setup:
NAD C326BEE (50Wx2)
Elite DV-47Ai Universal SACD/DVD-A
Citypulse DA7.2x II + TXCO DAC
B&W 685s
JL Fathom F112
Denon AH-D2000 Headphones


Top
Page 1 of 5 1 2 3 4 5 >

Who's Online
1 registered (govguru), 187 Guests and 2 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
jamescuz, Zilla8d3, waferman, picnicjc, Hedoboy
8709 Registered Users
Top Posters (30 Days)
butchgo 1
Forum Stats
8,709 Registered Members
88 Forums
11,327 Topics
98,693 Posts

Most users ever online: 476 @ 12/28/22 08:54 PM