Outlaw Audio home shop products hideout news support about
Page 2 of 4 < 1 2 3 4 >
Topic Options
#63731 - 02/07/07 04:14 PM Re: Very worried - apparently dead 990
mzpro5 Offline
Gunslinger

Registered: 12/05/05
Posts: 240
Loc: The Northcoast
I'm interested in when the people experiencing the problem purchased their 990's. Perhaps there is a problem with a particular "lot".

Also still not clear to me if all people with problem had the old or newer version of the firmware.
_________________________
Outlaw 990/7700
SVS 20-39 PC +
SVS MTS-01 towers, MCS-01 center, MBS-01 surrounds
Behringer A500
Samsung PN58A650, DirecTV HR-20 700
Sony CDP-545, Phillips CDR 765
Oppo BDP-93, Panasonic DMR E515
Technics SL-DL5
Squeezebox 3
Remote Harmony One

Top
#63732 - 02/07/07 06:18 PM Re: Very worried - apparently dead 990
Brian Quinn Offline
Deputy Gunslinger

Registered: 01/25/07
Posts: 8
Loc: USA
I'm still waiting to hear back from Outlaw. They've had my unit for over a week now. It's very interesting to me to hear that others are starting to have the same problems. When I have some news (which, Outlaw, I'm definitely waiting for), I'll let you all know. This is very frustrating.

Regarding some of your questions, I had the old firmware operating when I encountered these difficulties. I installed the new firmware, hoping that my problems were due to a corrupt system OS. No luck (although, according to the installer program, the firmware was installed successfully). As I mentioned, I even tried replacing the fuse - no luck.

Earwit and jrlouie, I'm sorry to hear that you're encountering the same problem. Your problems sound identical to mine - just to be clear, are you getting anything at all on the display screen? Or does it always remain blank? I'd also be interested to know if you were running the latest firmware when the problem happened, or the older firmware. But given that the firmware upgrade did nothing for the problem, this seems hardware related.

I received my unit in August 2005, from Outlaw.

Top
#63733 - 02/07/07 07:01 PM Re: Very worried - apparently dead 990
jrlouie Offline
Gunslinger

Registered: 03/05/06
Posts: 118
Loc: Missouri
-Purchased mine March 6th, 2006.
-I was already running newest version of firmware when problem happened.
-Display never illuminates. Only blue lights.
-System reset does not work.
-Very interstingly (this might help Outlaw diagnose), my 990 does not automatically completely turn off if I try starting it via the following inputs: CD, AUX. But, it never fully powers up. The lights turn blue, but no display and then just sits there. All other inputs cause it to turn back off.

Top
#63734 - 02/07/07 07:18 PM Re: Very worried - apparently dead 990
earwit Offline
Deputy Gunslinger

Registered: 02/07/07
Posts: 3
Loc: Texas
Brain,
I had the lastest software on the unit.
Exactly like your situation the blue light
would go on a few seconds, display would never
work, then go back to amber..

I purchased my unit right after they came out, I believe June 05.......

Top
#63735 - 02/08/07 07:38 AM Re: Very worried - apparently dead 990
Brian Quinn Offline
Deputy Gunslinger

Registered: 01/25/07
Posts: 8
Loc: USA
Intersting. Jrlouie, I never tried the CD or AUX inputs on my unit (as I had nothing connected). Earwit, did you have any luck with those inputs?

Top
#63736 - 02/08/07 07:54 PM Re: Very worried - apparently dead 990
jrlouie Offline
Gunslinger

Registered: 03/05/06
Posts: 118
Loc: Missouri
Well, so far I'm playing phone tag with Outlaw. The message they left me was to try a few more things so I obliged. Here is an update compiling all notes.
-Purchased mine March 6th, 2006.
-I was already running newest version of firmware when problem happened.
-Display never illuminates. Only blue light.
-Cycling the service switch does not help.
-System reset does not help.
-Re-downloading the latest firmware (that I was already running) and reinstalling it does not help. The loader software states success but when finalizing with a system reset, the display never shows system reset as it should and unit still won't power on.
-Starting via any input causes it to not power up.

I'll post an update once I hear back from Outlaw.

Top
#63737 - 02/09/07 01:03 AM Re: Very worried - apparently dead 990
Brian Quinn Offline
Deputy Gunslinger

Registered: 01/25/07
Posts: 8
Loc: USA
Jrlouie, what you're describing is identical to the problems mine had. And none of the remedies you've tried worked for me either. Outlaw will probably tell you to try replacing the fuse next - it's worth a go, but it didn't help me. Sorry to hear about your problems.

When I've heard back from Outlaw as to what they've found with my 990, I'll post an update.

Top
#63738 - 02/20/07 06:51 PM Re: Very worried - apparently dead 990
earwit Offline
Deputy Gunslinger

Registered: 02/07/07
Posts: 3
Loc: Texas
Been two weeks since Outlaw received the 990,
Still no word in regards toward repair status..

Top
#63739 - 02/20/07 09:26 PM Re: Very worried - apparently dead 990
Davin Offline
Gunslinger

Registered: 02/02/06
Posts: 34
Loc: Wisconsin
This really sucks!! I had the same type of problems with my Parasound AVC2500. I ended up fixing it myself. I found a bad voltage regulator in the power supply. Replaced it and never had a problem again. But I really do hope I do not experiance the same problems with my 990 which I might add will be here tomorrow. Good luck and let us know how this pans out
_________________________
http://webpages.charter.net/ravekid/IMG_6723.JPG
Outlaw 990
Parasound HCA 3500A
Parasound HCA 1500 X2
Parasound CDP 1000
2 CREST AUDIO FA901s (SUB AMPs)
SONY DVP 9000ES
PANAMAX MAX 1500
MONSTER AVS 2000 X2

Top
#63740 - 02/21/07 11:20 AM Re: Very worried - apparently dead 990
Scott Offline
Desperado

Registered: 01/07/10
Posts: 673
Hello All,

As has been previously stated in the Saloon, there have been a tremendous number of these products sold since its release. Having a few units with similar symptoms at the same time is nothing more than coincidence. These types of failures can occur as the result of a power surge, a part failure, an external short etc. Therefore, there is no reason to be concerned that your unit will fail in the future, as the service rate for the Model 990 simply does not support that likelihood.

Best,

Scott

Top
Page 2 of 4 < 1 2 3 4 >

Who's Online
0 registered (), 130 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
REP, caffeinated, WooWho, Ali, garyedward
8714 Registered Users
Top Posters (30 Days)
Forum Stats
8,714 Registered Members
88 Forums
11,328 Topics
98,694 Posts

Most users ever online: 579 @ 07/06/24 02:31 PM