Outlaw Audio home shop products hideout news support about
Topic Options
#29687 - 04/26/06 09:03 PM Blown center input on amp
wings of death Offline
Deputy Gunslinger

Registered: 10/23/05
Posts: 9
i get no sound at all.tried diff speakers and none work on the center input. started when i moved it to new place in room. can't call tech it's late.
there is no reason for it to be blown. me and a friend moved it about 14feet away from where it was.
can i still get it repaired or replaced?

Top
#29688 - 04/26/06 10:10 PM Re: Blown center input on amp
E'pin Sen Ob Offline
Gunslinger

Registered: 05/04/05
Posts: 226
Loc: USA
Need some info on type of speakers, how old they are, type of amps, processor or rec. you are using. Give us some details on what you got.

Also, I know you have probably done this already but I still have to ask. Did you check inputs, speaker connections, no buttons were pushed, and make sure you have all your settings right. Alot of times it's the simple things that get us. Go through and check them all.
_________________________
ONE MAN SHOOTIN GALLERY

MY HOME THEATER PICTURES http://community.webshots.com/user/bonesnipe

Top
#29689 - 04/26/06 10:42 PM Re: Blown center input on amp
wings of death Offline
Deputy Gunslinger

Registered: 10/23/05
Posts: 9
infinity beta 50 for front beta cc360 center beta es 250 for side suround and rear all less then a year old, everything is set up right checked everything no buttons pushed.

Top
#29690 - 04/26/06 11:32 PM Re: Blown center input on amp
wings of death Offline
Deputy Gunslinger

Registered: 10/23/05
Posts: 9
i'm gonna disconect everything and re conect everything b/c now my front L and R is gone just like that. so now i have no front stage except the sub. i have no idea what is going on with it at all.
i'll let you know what happens when i re do it.

Top
#29691 - 04/26/06 11:56 PM Re: Blown center input on amp
wings of death Offline
Deputy Gunslinger

Registered: 10/23/05
Posts: 9
now i get no picture thru the pre/pro the sat and xbox 360 has no pic but dvd works. i'm so confused. everything is perfectly conected and everything is going wrong. i think things are getting shorted out i don't know and have no idea. i'm really stuck.

Top

Who's Online
0 registered (), 105 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Newest Members
Hedoboy, naowro, BeBop, workarounder, robpar
8705 Registered Users
Top Posters (30 Days)
Forum Stats
8,705 Registered Members
88 Forums
11,326 Topics
98,691 Posts

Most users ever online: 476 @ 12/28/22 08:54 PM